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Structure informs function of proteins

Source: PDB, www.rcsb.org
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How do we determine protein structures?
Method Sample Instrument Data Advantages Limitations

X-ray crystallography Crystals Synchrotron Diffraction pattern • High-res data

• Very common
• No size restriction

• Dependent on 

crystallization
• Limited 

conformations 

Cryo-electron 

microscopy

Sample vitrified

on grids

Electron microscope Micrographs • Can capture 

states
• Small amount of 

sample required

• Fast sample prep

• Size limit 

(smaller = harder)
• Preferred 

orientation

• Computationally 
intensive

Nuclear 

Magnetic
Resonance 

Spectroscopy

Sample in solvent NMR Spectrometer NMR spectra Only method for real-

time, in-solution 
motion detection

• Size limit

(larger = harder)
• Need a lot of very 

pure sample



Source: Biomolecular Crystallography: Principles, Practice, and Application to Structural Biology

High resolution

Low resolution

Resolution and information level 

Electron density map

Atomic model



Where to find protein information

UniProt: Universal Protein Resource
www.uniprot.org

RCSB PDB: Protein DataBank
www.rscb.org

protein sequence and functional information central repository of biomolecular structures



AlphaFold

Database: https://alphafold.ebi.ac.uk/

 models for almost every protein in Uniprot 

Revolutionary tool for structural biology, but proteins are chaotic

 post-translational modifications (PTMs), environment, ligands, oligomerization etc…

https://alphafold.ebi.ac.uk/entry/Q8N3Z6 

https://alphafold.ebi.ac.uk/
https://alphafold.ebi.ac.uk/entry/Q8N3Z6


Useful resources 
Name Link Purpose

UniProt https://www.uniprot.org/ Protein information database

Protein Data Bank (PDB) https://www.rcsb.org/ Protein structure repository

PyMOL https://pymol.org/ Download PyMOL

PyMOL wiki www.pymolwiki.org Information on PyMOL such as examples of settings

ConSurf http://consurf.tau.ac.il Evolutionary conservation of amino/nucleic acid sequences

PISA www.ebi.ac.uk/pdbe/pisa/ Protein interface and assemblies

Dali http://ekhidna2.biocenter.helsinki.fi/dali/ Search PDB for similar structures

EMDB https://www.ebi.ac.uk/emdb/ Repository for EM/ET data

AlphaFold database https://alphafold.ebi.ac.uk/ Database of AlphaFold predictions

ChimeraX https://www.cgl.ucsf.edu/chimerax/ Another visualization software, works well with EM maps

https://www.uniprot.org/
https://www.rcsb.org/
https://pymol.org/2/
http://www.pymolwiki.org/
http://consurf.tau.ac.il/
http://www.ebi.ac.uk/pdbe/pisa/
http://ekhidna2.biocenter.helsinki.fi/dali/
https://www.ebi.ac.uk/emdb/
https://alphafold.ebi.ac.uk/
https://www.cgl.ucsf.edu/chimerax/


overview of structure files

model

• the coordinates of the atoms

• file types: .pdb, .cif

map

• the experimental data with 
which you can place atoms 
into position (x-ray or EM)

• can also be called structure 
factors or map coefficients

• file types: .map, .mrc, .ccp4, 
.mtz, .cif

Note: Cartoon (ribbon) representation is 

an artistic interpretation of structures 

invented by Dr. Jane Richardson (Duke)

https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-

duke

https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke
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https://stories.duke.edu/sciences-mother-of-ribbon-diagrams-celebrates-50-years-at-duke


Header

Atom coordinates

The primary information stored in the PDB archive consists of coordinate files that list of 

atoms and their 3D location in space stored as plain text (ASCII) files

Either as .pdb or mmcif (.cif) format



what’s in a pdb file

atom #, atom name, residue name, chain id, residue number, x/y/z 

coordinates of the atom, occupancy, bfactor, atom element



Why and how to visualize protein structures?

• To observe and analyze a structure of interest. 

• To make images or movies to illustrate certain properties of the 

structure of interest.

• There are numerous programs and websites to visualize 

macromolecular structures. PyMOL and UCSF Chimera / ChimeraX 

are most used. 



PyMOL tutorial



PyMOL interface

In this ppt, 

[square brackets] 

indicates these 

buttons



1. Loading structures

File > Get PDB > 1tup

OR

1. Go to PDB website: www.rscb.org

2. Find molecule of interest using search bar

Search for: p53 complexed with dna

3. Download Files > PDB Format > 1tup.pdb file 

and open it in PyMOL

using File>Open 

OR 

Fetch .pdb file directly to PyMOL using 

File>Get PDB… and providing 4 letter code 

from PDB entry: 1TUP 

OR 

Command line: fetch 1tup 

http://www.rscb.org/


1tup.pdb loaded in PyMOL



2. Mouse controls

Rotate 

Zoom 

Move (click)

Slab depth (wheel)

and position (Shift + wheel)

If you get lost:

Zoom>All or Orient

Mouse functions + modifier keys:



Mouse modes

Editing Mode: rotate bonds, replace 

atoms, physically move atoms and 

residues, etc.

Viewing Mode: view, rotate, translate, 

and change the representations of 

objects (you will use this mostly)



General notes on PyMOL

• Save sessions (File->Save session…) from time to time

• Use the Zoom or Orient buttons on the top panel if you get lost

• To change display quality, select Display > Quality > Maximum quality (or other)



Exercise 1: Adjusting view and slab 

1. Reset the view.

• Locate DNA in the complex, adjust view and 

slab so you can see single base pair and 

move the slab so you can see single base-

pair as you move the slab along Z-axis.

2. Reset, look around

• How many protein chains are bound to this 

dsDNA?

• Do all the protein chains bind DNA similarly?



3. Representations

Different 

representations 

convey different 

information



Object and Selections panel – used to change representations and much more

Object

Selection

Selections and objects play slightly different roles in PyMOL.

- An Object can be created from selections

- Can be moved and aligned! 

- A Selection belongs to a specific object

- Selections are used to modify representation of parts of an object

- You cannot display a selection without displaying its original object source



4. Selections – how to make them
There are multiple ways to perform selections:

By clicking on the molecule:

• Single left mouse click be default selects single residue 

(can also be used to select atom/chain/molecule etc. depending by setting in Mouse-

>Selection Mode menu)

•  Shift + Left Mouse button selects a box 

By clicking on the sequence:

• Select Sequence On in the Display Menu to show sequence; click on the residues

OR

command line: https://pymolwiki.org/index.php/Selection_Algebra 

https://pymolwiki.org/index.php/Selection_Algebra


Exercise 2: Changing representations 

1. Reset the view.

2. Hide waters: 
[H] > waters

3. Select individual protein chains and change 
their colors: 
a. Change the mouse selection mode to 
chains. 
b. Click on a chain. In the Object Panel, click 
on [C] button of <sele>, choose a color.

4. Set the DNA representation to licorice sticks 
and change color by element:
Make sure your mouse selection mode is still 
chains.
a. Click the 2 DNA strands. [S] > as > licorice 
– sticks.
b. [C] > by element > choose a color palette.

2

3a

4a 4b

Ha An’s colors:

pink, palegreen, slate



Making Selections using Sequence Display 

-Select Display->Sequence On to show sequence; click on the residues

-Colors of sequence corresponds to colors in structure

-0 = water

-Residue number corresponds to the residue directly below the first digit

-Display->Sequence Mode->Residue Names changes Sequence display to three-letter amino 

acid code

if you don’t see the numbering, might need to change the background 

color to white (Display > Background > White)



How selections are indicated

sequence 

selected

residues 

selected

Selection

(you can 

rename it 

too)



Selections – command line:

Command line offers powerful way of making selections 

Hierarchy: model → chain → resn (residue name) →  resi (residue number) → name (atom name)

Examples:
- select chain A – select chain A

- select resn lys – select all lysines

- select resi 175 - select residue 175 in all chains
- select (resi 175 or resi 245) and chain B 

  - select residues 175 and 245 in chain B
- select interface, (chain B within 4 of chain E:F) or (chain E:F within 

4 of chain B) – make selection named interface with all atoms located less than 4A apart 

between chain B and chain E:F

Type: help select to see help 

Full explanation: https://pymolwiki.org/index.php/Selection_Algebra 

https://pymolwiki.org/index.php/Selection_Algebra


Selection and Objects 

• rename selection: <sele> [A] > rename selection

• copy selection to new object: <sele> [A] > copy to object

• select all residues within 4Å of selection: <sele> [A] > modify > around > residues within 4 A
(this selects the atoms; you can show sidechains by going to [S] > sidechain > stick)



Exercise 3: Working with sequences

Certain residues are most frequently mutated in cancer:

R175, G245, R248, R249, R273, R282. 

Select and show the side chains for these residues 

in chain B (middle protein molecule) and look at them.

Q: Where are these residues located? 

Q: What could be the role of these residues? 

• Display > Sequence

• Make sure your selection mode is ‘Residues”



Exercise 3: Working with sequences

Q: Where are these residues located? 

Q: What could be the role of these residues? 



5. Making measurements 

click the first atom, then 

click the second atom



Exercise 4: Measure the coordinating distances of the Zn atom 
• Select a Zn atom, expand the selection to select coordinating residues 

<sele> [A] > modify >  expand > by 4 A, residues

• change the representation of the side chains to show sticks
<sele> [S] > sidechain > sticks

• you can also change the color of this selection:
<sele> [C] > by element > choose your color palette

• In the menu bar, Wizard > Measurement to turn on the measurement 
option click two atoms to measure the distance between them.



Exercise 4: Measure the coordinating distances of the Zn atom 

The zinc ion has been shown to be important in DNA binding. 

Q: Which residues coordinate zinc? 

Q: What are the coordinate bond lengths? 

Q: What role does the zinc have?



Exercise 5: Showing electrostatics 

• Create new individual objects that contain the protein 
chains A, B and C individually
(use the command split_chains 1tup)

• Generate electrostatic potential surfaces quickly:
[A] > generate > vacuum electrostatics > protein contact 
potential

• Do you see any electronegative or electropositive patches? 
Where are they located?



Better (more proper) way to generate electrostatics by APBS:

• Plugin > APBS electrostatics > choose your selection > Run (takes some time) 

wait till “Finished with Success” popup

If this errors out for you, try going into Prepare Molecule > Options > Method: change to “use formal_charge and vdw”



Exercise 6: Align the three protein chains 

• you should have the 3 protein chains in separate objects

• align chains A and C to chain B

[A] > align > to molecule > chain B

• Are the proteins adopting different conformations?

You can align all proteins to a currently selected one 

A→Action→Align→All to this

or align proteins one by one
A→Action→Align→To Molecule 



Exercise 6: Align the three protein chains 

• you should have the 3 protein chains 

in separate objects

• align chains A and C to chain B

[A] > align > to molecule > chain B

• Are the proteins adopting different 

conformations?

Executive: RMSD = 0.429 (169 to 169 atoms)



Exercise 7: perform an in silico alanine mutation 

• Select R175 in chain A, show and color its sidechain.

• expand the selection to residues within 5 Å and show sidechains

• Go to menu bar Wizard > Mutagenesis

• In the panel on the right, click on ‘No Mutation’, select ALA.

• Click on the R175 that you want to mutate

• Then click Apply

• What could be an effect of this mutation?



10. Make a figure

Ha An’s settings to 

make it look pretty:

set spec_count, 0

set spec_reflect, 1

set ray_shadows, off

set ray_trace_mode, 1

https://pymolwiki.org/index.php/Ray 

Reset everything (can just open a new window)

1tup

Recolor each protein chain a different color

Set DNA chains to be sticks, color by element

Draw/Ray: Ray(slow) > save image as > png to somewhere

https://pymolwiki.org/index.php/Ray


Bonus: look at electron density of an inhibitor

Explore electron density in the crystal structure of COVID-19 main 

protease in complex with an inhibitor N3 (pdb: 6lu7)

Get pdb… 6lu7: PDB and 2FoFc map

• Hide waters
• Create a mesh representing the map:

- Action > mesh > @level 1.0
    - isomesh map, 6lu7_2fofc, 1, 3bep, carve = 2.5

• Color the mesh (e.g. blue > density)
• Color protein chain and inhibitor ([C]->color by chain, [S]->as 

licorice (sticks) 

• Explore electron density for the inhibitor
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